OpenBVE – Ubuntu 14.04 LTS

English summary: many users found that OpenBVE doesn’t work on Ubuntu 14.04. It was then realised that the libgdiplus package in Ubuntu 14.04 is the cause of the problem. The workaround is to remove it and replace it with the one from the Saucy repositories. To do this, follow the commands below. In some cases there are separate commands for 32 bit and 64 bit systems.

Az utóbbi hónapokban sokunknak fejtörést okozott, hogy az OpenBVE nem volt hajlandó működni az új Ubuntu 14.04 LTS-en. A hibát jelentették a Launchpaden és Chris Lees rá is jött arra, hogyan lehet azt kikerülni. A probléma a Trustyba bekerült libgdiplus csomagban rejlik, ezért a megoldás röviden az, hogy eltávolítjuk a libgdiplus csomagot, majd a Saucy tárolóban levő libgdiplust telepítjük fel. A lépések a következők:

  1. Eltávolítjuk a meglévő libgdiplus
    sudo apt-get remove libgdiplus
  2. Letöltjük a Launchpadről a Saucy tároló libgdiplus csomagját.
    32 bites rendszerre:

    wget http://launchpadlibrarian.net/109777289/libgdiplus_2.10-3ubuntu1_i386.deb

    64 bites rendszerre:

    wget http://launchpadlibrarian.net/109777287/libgdiplus_2.10-3ubuntu1_amd64.deb
  3. Feltelepítjük a Saucy tárolóból mentett libgdiplust.

    32 bites rendszeren:

    sudo dpkg -i ~/libgdiplus_2.10-3ubuntu1_i386.deb

    64 bites rendszeren:

    sudo dpkg -i ~/libgdiplus_2.10-3ubuntu1_amd64.deb

    Ha az elérési út nem stimmel, írd át a parancsban, vagy használd a Szoftverközpontot a telepítéshez. Az itt leírt parancsok esetében stimmelni fog az elérési út.

  4. Meg kell akadályoznunk, hogy egy frissítéssel a libgdiplus is frissüljön:
    sudo apt-mark hold libgdiplus
  5. Telepíthetjük az OpenBVE-t Szoftverközpontból vagy az alábbi paranccsal:
    sudo apt-get install openbve

Végeztünk, mehet a játék!

A legújabb openBVE Ubuntu 10.04-en

Aki Ubuntut és openBVE-t is használ, talán tudja, hogy az Ubuntu Szoftverközpontjából rendszerint elég régi openBVE változatot lehet letölteni. Ezért készítettem egy leírást arról, hogy hogyan lehet a legújabb openBVE verziót Ubuntu 10.04-re és 10.10-re telepíteni. Az írás Anthony Bowden munkájára alapoz. A dokumentum megtalálható az Útmutatók oldalon.

 Letöltés · OpenBVE Ubuntu 10.04-en 

I have written a Hungarian tutorial about how to set up the latest openBVE on Ubuntu 10.04 or 10.10. If you don’t speak Hungarian but are interested in this  you should read Anthony Bowden’s document on this subject.